Thursday, December 26, 2013

Gradle 1.9 and Android plugin 0.7+

Latest update of our plugin brings changes in Gradle support. Similarly as in Android Studio 0.4 it now requires Gradle 1.9 for its projects and use of android plugin version 0.7+. This update opens door for future support of other test types than instrumented tests. Stay tuned. The API is under development but hopefully we will find a good way how to add testing related features soon.

Related to this change is an update of Android SDK libraries to 22.4.0. Most users should not be affected by this change.

4 comments:

  1. Hello,
    I have unfortunately agreed on nb android proposed update, and now netbeans doesn't start anymore, it says that 22.4.0 is needed and I only have 22.2
    It seems that 22.4.0 is not official out yet, how can I fix my issue?
    https://developer.android.com/tools/sdk/tools-notes.html
    Thank you,
    Nini.

    ReplyDelete
  2. Hi there,

    After the latest update I can no longer deploy to a device or start an AVD from within Netbeans. I check the Android site and like Nini points out: the latest available SDK is 22.3.

    Either the plugin need a downgrade, or some other compatibility fix.

    ReplyDelete
    Replies
    1. Don't mean to sound "entitled" or anything like that. Just trying to help by pointing out an issue :)

      Delete
    2. There is a difference between Android SDK components and Android libraries bundled to NBAndroid. I suggest you to reinstall the plugin to make sure all dependencies are correctly downloaded and installed.
      Also please some other channel suggested ar to discuss problems. Blog comments are not good for this.

      Delete