Sunday, February 27, 2011

Development builds

We have continuous build set up now. It means that the latest bug fixes and improvements are available as soon as they are pushed to main repository and build passes with all existing tests. If you think you are going to try these just add or update your Update Center URL to http://deadlock.netbeans.org/hudson/job/nbandroid/lastStableBuild/artifact/build/updates/updates.xml.

There were few bugfixes added during the last week and some small changes in the project UI to make it simpler to detect cases when the project needs to be updated. The idea is to support project generated using SDK tools directly - just open them using open project dialog and it should be possible to edit build and deploy. Generated build.xml is used for building then and we will add more Android specific features in the future.

I hope there will be just one extra step for simple projects previously developed in Eclipse: open project customizer and click OK after checking that there is a correct build target selected (if there are no build targets you will have to specify SDK location in Options dialog).

Surely there are many things missing and you can send your feedback to a users mailing list of this project or submit a bug/RFE at our JIRA bug tracking system or post to a forum. The next priorities will be set according to this input.

7 comments:

  1. Using lastStableBuild is wiser than lastSuccessfulBuild; do not want to get updates when there are test failures!

    ReplyDelete
  2. I am having trouble installing the plugins,
    I get the following error for both the 1.1 and 1.2 versions of the nbm on both nb 6.9 and 7.0b

    "The Plugin Installer found problem timeout of loading Android Ddmlib[com.android.ddmlib/1.2] while install the following plugins:
    Android Ddmlib"

    any ideas??

    ReplyDelete
  3. I am having trouble installing the plugins,
    I get the following error for both the 1.1 and 1.2 versions of the nbm on both nb 6.9 and 7.0b

    "The Plugin Installer found problem timeout of loading Android Ddmlib[com.android.ddmlib/1.2] while install the following plugins:
    Android Ddmlib"

    any ideas??

    ReplyDelete
  4. When i select to install Android Test Runner for Netbeans 7.0+ I get the error "The plugin common test runner api is requested in version >=1.19.1 but only 1.18 was found."

    ReplyDelete
  5. This comment has been removed by a blog administrator.

    ReplyDelete
  6. This comment has been removed by a blog administrator.

    ReplyDelete